import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "xxx(?!(.*STRING1.*))xxx";
final String string = "xxxxxx\n"
+ "xxxSTRING1xxx\n"
+ "xxxSTRING2xxx\n"
+ "xxxSTRING3xxx\n\n\n\n"
+ "import org.apache.spark.rdd.RDD\n\n"
+ "df.rdd\n"
+ " .map\n\n"
+ "df.rdd.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}