const regex = /xxx(?!(.*STRING1.*))xxx/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('xxx(?!(.*STRING1.*))xxx', 'gmi')
const str = `xxxxxx
xxxSTRING1xxx
xxxSTRING2xxx
xxxSTRING3xxx
import org.apache.spark.rdd.RDD
df.rdd
.map
df.rdd.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}