using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\s)#(\w+)";
string input = @"#gethashtagsregexp
$1. Blank Space
$2. Hashtag content #:content";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}