re = /(^|\s)#(\w+)/
str = '#gethashtagsregexp
$1. Blank Space
$2. Hashtag content #:content'
# Print the match result
str.match(re) do |match|
puts match.to_s
end