#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[A-Za-z\x{0600}-\x{06FF}\x{1000}-\x{1021}_-][-\w]*"
Local $sString = "Abyssinian 987" & @CRLF & _
"Burmese a1a" & @CRLF & _
"Dragon Li 2B" & @CRLF & _
"987 Cat" & @CRLF & _
"cat 987 Toyger" & @CRLF & _
"cat A1A Siamese" & @CRLF & _
"1" & @CRLF & _
"abc-Burmese-a1a"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)