re = /(?<!Account n.:\s\d{3}.)(?<!(\d|\/))\d{7}(?!.*has been received and is being reviewed by)(?!.*has been solved. To reopen)(?!\w)/m
str = 'Account n.: 243-479688.71J
Your request (443760) has been solved. To reopen this request, reply to this email..
Article DOI: 10.3389/fchem.2020.500600
Article DOI: 10.3389/fchem.2020.5006001
Article DOI: 10.3389/fchem.2020.50060'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end