$re = '/((\b(?:[a-z]|[^\x00-\x7F]){1,}\b).*?)(\b\2\b)(.*)$/mix';
$str = 'Green shirt green hat
Green shirt greenish hat
You are an artistically gifted musically gifted individual
Naïve question naïve answer';
$subst = "\1and\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;