$re = '/^#[a-f0-9]{6}(?:,\s*#[a-f0-9]{6})?$/m';
$str = 'rgb(255,0,24)
rgb(255, 0, 24)
rgba(255, 0, 24, .5)
hsla(170, 23%, 25%, 0.2 )
#fff
#f2ewq
#0f243e
#0f243e,#3f54ae
#0f243eпп
#0f243eбб,#3f54aeпп
0x00ffff
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);