use strict;
my $str = 'rgb(255,0,24)
rgb(255, 0, 24)
rgba(255, 0, 24, .5)
hsla(170, 23%, 25%, 0.2 )
#fff
#f2ewq
#0f243e
#0f243e,#3f54ae
#0f243eпп
#0f243eбб,#3f54aeпп
0x00ffff
';
my $regex = qr/^#[a-f0-9]{6}(?:,\s*#[a-f0-9]{6})?$/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}