#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im).*?1920x1200.*$(*SKIP)(*F)|(?:\d+[a-z]|[a-z]+\d)[a-z\d]*"
Local $sString = "group1:" & @CRLF & _
"2aa" & @CRLF & _
"a2" & @CRLF & _
"2aaaaaa" & @CRLF & _
"aaaa2" & @CRLF & _
"aaa2aaaa" & @CRLF & _
"2222a2222-2222-aaaa" & @CRLF & _
"sdfzugsdufz-aaaaa7-7aaaa" & @CRLF & _
"sdfz/////...ugsd33ufz_//__-aaaaa7__///-7aaaa" & @CRLF & _
"" & @CRLF & _
"group-two:" & @CRLF & _
"aaaaaa" & @CRLF & _
"22222" & @CRLF & _
"aaa-222-aaa-aaa" & @CRLF & _
"aaaaa222aaa1920x1200bbbbb1234556789" & @CRLF & _
"aaa1920x1200-" & @CRLF & _
"aaaaf344t---1920x1200aaa------" & @CRLF & _
"aaaaaaaaaaaaaaaaa-1920x1200" & @CRLF & _
"aa456456a-1920x1200-dfgfdg656dfg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")