import Foundation
let pattern = #".*?1920x1200.*$(*SKIP)(*F)|(?:\d+[a-z]|[a-z]+\d)[a-z\d]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
group1:
2aa
a2
2aaaaaa
aaaa2
aaa2aaaa
2222a2222-2222-aaaa
sdfzugsdufz-aaaaa7-7aaaa
sdfz/////...ugsd33ufz_//__-aaaaa7__///-7aaaa
group-two:
aaaaaa
22222
aaa-222-aaa-aaa
aaaaa222aaa1920x1200bbbbb1234556789
aaa1920x1200-
aaaaf344t---1920x1200aaa------
aaaaaaaaaaaaaaaaa-1920x1200
aa456456a-1920x1200-dfgfdg656dfg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)