using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=file\s).*?(?=\s*>)";
string substitution = @"$0 xml:space=""preserve""";
string input = @" <file datatype=""plaintext"" original=""question1.html"" source-language=""eng-ZZZ"" target-language=""rus-EST"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}