re = /\((?!\))/
str = '"myclass.test() and(myclass.mytest() and myclass.test()) or (myclass.mytests())"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end