re = /(\S+?)\s*=\s*(\S+)/m
str = 'first_name=value1
secon_name=value2
date_b = 12.01.1989'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end