using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<img src=.*\/storyimages\/.*?>";
string substitution = @"";
string input = @"<br><img src=""/storyimages/myimage.jpg"" align=""right"" WIDTH=""105"" HEIGHT=""131""><b>(CNS) </b>Lorem ipsum dolor...";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}