const regex = /((?:https?:\/\/)?www\.ex[ma][ma]ple\.com\/tp\/\S+\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:https?:\\\/\\\/)?www\\.ex[ma][ma]ple\\.com\\\/tp\\\/\\S+\\d+)', 'gm')
const str = `
http://www.exmaple.com/tp/123
www.exmaple.com/tp/abc/123
https://www.exmaple.com/tp/123
http://www.example.com/tp/123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}