$re = '/(^FT_)(FMS|LOC|MFG|SRM|CRM|HCM|SOE)(_)([a-zA-Z0-9]+(_))*([a-zA-Z0-9]+)$/';
$str = 'FT_FMS_HJASGDJAG312_ZZZZZ_XDCDCfdghfh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);