using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/(www)?[a-zA-Z0-9]+\.(com|ru|net)\/(\w+)*";
string input = @"http://google.com/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}