package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(<p[^>]+")([^>"]+)`)
var str = `<p id="tem" style="text-align: justify;"><span style="font-size: 11pt;">hello world<br /></span></p>
<p style="text-align: justify;">test</p>
<p > </p>
<p> </p>`
var substitution = "$1$2margin:0;"
fmt.Println(re.ReplaceAllString(str, substitution))
}