use strict;
my $str = '<p id="tem" style="text-align: justify;"><span style="font-size: 11pt;">hello world<br /></span></p>
<p style="text-align: justify;">test</p>
<p > </p>
<p> </p>';
my $regex = qr/(<p[^>]+")([^>"]+)/miup;
my $subst = '$1$2margin:0;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";