$re = '/(<p[^>]+")([^>"]+)/miu';
$str = '<p id="tem" style="text-align: justify;"><span style="font-size: 11pt;">hello world<br /></span></p>
<p style="text-align: justify;">test</p>
<p > </p>
<p> </p>';
$subst = "$1$2margin:0;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;