#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?miu)((?<=\<)[^>]+style=")([^>"]+)"
Local $sString = "<p id="tem" style="text-align: justify;"><span style="font-size: 11pt;" >hello world<br /></span></p>" & @CRLF & _
"<p style="text-align: justify;">test text-align: justify;</p> style="text-align: justify;"" & @CRLF & _
"<p > </p>" & @CRLF & _
"<p> </p>"
Local $sSubst = "$1$2margin:0;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)