re = /"[^"]*"|\S+/m
str = 'this is a "text field" need "to replace"'
subst = '+$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result