$re = '/(\w)\1\1\K\1+/';
$str = 'Hellooaaaoooo Louis, waaaat\'s up pal';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;