import Foundation
let pattern = #"(?<=^label )\S+(?!.*(?:\n(?!label).*)*?\n[ \t]*\[end_timeline\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
label Colorcode (Object)
Dialog
Speaker: "Text"
Speaker 2: "[i]Text[/i]! [pause={pause.medium}] more text."
do function_name("parameter", {parameter})
# comment, there are no inline-comments
[end_timeline]
label Maroon (Guitar)
Speaker: "Text"
[end_timeline]
label Pink (Chest)
Speaker: "Text"
label Königsblau (Wardrobe)
Speaker: "Text"
Speaker: "Text"
Speaker: "Text"
[end_timeline]
label Azur (Sorcerers Hat)
Speaker: "Text"
# [end_timeline]
label Jade (Paintings)
Speaker: "Text"
label Gras (Ship in a Bottle)
Speaker: "Text"
Speaker: "Text"
[end_timeline]
label Goldgelb (Golden Apple)
Speaker: "Text"
[end_timeline]
label Himmelblau (Helmet)
Speaker: "Text"
Speaker: "Text"
Speaker: "Text"
Speaker: "Text"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)