# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bwidth:\s*[.0-9]*pt;//g;t' <<< "width:453.1pt;border:solid windowtext 1.0pt; "