use strict;
my $str = 'width:453.1pt;border:solid windowtext 1.0pt; ';
my $regex = qr/\bwidth:\s*[.0-9]*pt;/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";