re = /\bwidth:\s*[.0-9]*pt;/
str = 'width:453.1pt;border:solid windowtext 1.0pt; '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result