import Foundation
let pattern = #"\bwidth:\s*[.0-9]*pt;"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"width:453.1pt;border:solid windowtext 1.0pt; "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)