$re = '/\n\s{0,3}<.*[^>]+|<sub>.*?<\/sub>|`.*?`/m';
$str = 'something1
<sub>
something2
<div class=\'myclass\'>something3</div>
</sub>
<div class=\'myclass\'>something4</div>
something5
<div class=\'myclass\'>something6</div>
<div class=\'myclass\'>something7</div>
`<div>something8</div>`
something9';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;