using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=#region VARIAVEIS GLOBAIS).*?(?=#endregion)";
string input = @"#region VARIAVEIS GLOBAIS
string aux1 = ""teste"";
string aux2 = ""teste2"";
string aux3 = ""teste3"";
string aux4 = ""teste4"";
string aux5 = ""teste5"";
#endregion";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}