#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(ENERGIA ELETRICA CONSUMO(.|\n)*?%)"
Local $sString = ""5758 6128 370 kWh 1 370 kWh 11,93 kWh 12/07/2019 01/08/2019" & @CRLF & _
"Mês kWh Dt.Pgto. Valor" & @CRLF & _
"06/2019 355 17/06/2019 343,79" & @CRLF & _
"NOTA FISCAL/CONTA DE ENERGIA ELÉTRICA N° 085.976.711 - SÉRIE B" & @CRLF & _
"Emitida em 03/07/2019" & @CRLF & _
"05/2019 332 14/05/2019 306,84" & @CRLF & _
"Produto Valor Valor Base Aliq." & @CRLF & _
"04/2019 415 29/05/2019 378,67" & @CRLF & _
"Descrição Un. Consumo Unitário Total Cálc. ICMS" & @CRLF & _
"03/2019 308 14/05/2019 269,81" & @CRLF & _
"ENERGIA ELETRICA CONSUMO kWh 370 0,787324 291,31 291,31 29,00%" & @CRLF & _
"02/2019 347 26/04/2019 305,09" & @CRLF & _
"ENERGIA CONS. B.AMARELA kWh 0,54 0,54 29,00%" & @CRLF & _
"01/2019 341 11/03/2019 324,39" & @CRLF & _
"12/2018 301 26/12/2018 287,83""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)