use strict;
my $str = 'AAAAAA';
my $regex = qr/(.{2})/mp;
my $subst = '$1bbb';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";