re = /.*\/(?<a>[^\']+)'\sContent/m
str = ' 2018-11-26 05:27:57,330 [http-nio-228.0.0.1-80-exec-653] [INFO ] (o.a.e.UploadServiceImpl:360) - Deploy to \'raven-snapshots:com/mayhem/xmen/edm-aggregator/1.0.0-SNAPSHOT/edm-aggregator-1.0.0-SNAPSHOT.rom\' Content-Length: 710
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end