$re = '/^((?:[0-9A-Fa-f]{2}(?:[:-]?)){7}(?:[0-9A-Fa-f]{2}))$/m';
$str = '00:13:a2:00:41:8b:93:7a
0013a200418b937a
AD:12:13:FC:14:EE:FF:FF
ad-12-13-fc-14-ee-ff-ad';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;