package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([^ .]+ )*\S*\.\S+)`)
var str = `file1.txt .project file2.jpg tricky file name.txt other tricky filenames containing áéÃőéáóó.gif`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}