// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(([^ .]+ )*\S*\.\S+)").unwrap();
let string = "file1.txt .project file2.jpg tricky file name.txt other tricky filenames containing áéÃőéáóó.gif";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}