using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:([a-z]{2,})_)?(\d+)_([a-z]{2,}\d+)_(\d+)$";
string input = @"SH_6208069141055_BC000388_20110412101855
6208069141055_BC000388_20110412101855";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}