const regex = /(?:([a-z]{2,})_)?(\d+)_([a-z]{2,}\d+)_(\d+)$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:([a-z]{2,})_)?(\\d+)_([a-z]{2,}\\d+)_(\\d+)$', 'igm')
const str = `SH_6208069141055_BC000388_20110412101855
6208069141055_BC000388_20110412101855`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}