$re = '/(?:([a-z]{2,})_)?(\d+)_([a-z]{2,}\d+)_(\d+)$/im';
$str = 'SH_6208069141055_BC000388_20110412101855
6208069141055_BC000388_20110412101855';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);