using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\\+CPIN: (.+)(,(.+))?$";
string substitution = @"\g<0>";
string input = @"+CPIN: MT PIN-UNLOCKED";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}