use strict;
my $str = '+CPIN: MT PIN-UNLOCKED';
my $regex = qr/^\\+CPIN: (.+)(,(.+))?$/ip;
my $subst = '\\g<0>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";