$re = '/a(b.+)?z/';
$str = 'az
abz
abcz
';
$subst = "a:$1z";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;