$re = '/\s*[Cc]:(?:(?:\/|\\\\{1,2})\w+)+\.\w+/';
$str = 'C:\\Users\\esteban\\Desktop\\Java_file_testing\\file3.txt
C:/Users/esteban/Desktop/Java_file_testing/file3.txt
C://Users//esteban//Desktop//Java_file_testing//file3.txt
c:\\\\Users\\\\esteban\\\\Desktop\\\\Java_file_testing\\\\file3.txt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);