$re = '/\\\\[a-zA-Z\h]+\\\\/m';
$str = 'WORK ORDERS\\Subdivision Subdivision\\Sec. 64\\72751401_123 street dr.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);