import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-I.*?(?=\"))";
final String string = "1334 execve(\"/home/y/bin64/ccache\", [\"/home/y/bin64/ccache\", \"/usr/bin/g++\", \"-fPIC\", \"-g\", \"-O2\", \"-Wall\", \"-pipe\", \"-MD\", \"-MP\", \"-D_REENTRANT\", \"-DLINUX\", \"-D_GNU_SOURCE\", \"-D_THREAD_SAFE\", \"-DUSE_STD_YUTSTRING\", \"-DNO_FACTORY\", \"-I/home/lniu/component/.build/include\", \"-I../include/\", \"-I../include/sample/\", \"-I/home/include64\", \"-I/home/include\", \"-I/home/lniu/sample\", \"-I/home/lniu/sample/../libraries\", \"-o\", \"x86_64-linux-gcc/sample\"], [/* 63 vars */]) = 0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}