const regex = /growth|(?:acquisition|lead gen(?:eration)?|demand gen(?:eration)?|outbound|bdr|abm|account based marketing)\s*manager?|g(?:o(?:-|\s)to(?:-|\s))?m(?:arket)?|gtm\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('growth|(?:acquisition|lead gen(?:eration)?|demand gen(?:eration)?|outbound|bdr|abm|account based marketing)\\s*manager?|g(?:o(?:-|\\s)to(?:-|\\s))?m(?:arket)?|gtm\\b', 'gmi')
const str = ` "Revenue Ops Manager",
"Growth Marketing Manager",
"CEO",
"Director of Operations",
"Sales Ops Analyst",
"VP of Sales",
"Marketing Operations Specialist",
"Lead Generation Manager",
"Product Ops Director",
"GTM Strategy Lead",
"Head of Growth",
"Chief Marketing Officer",
"Director of Business Development",
"Junior Revenue Analyst",
"Freelance Growth Consultant",
"CTO and Product Owner",
"Sales Development Representative",
"Intern Marketing Operations",
"Business Systems Administrator",
"Country Manager and COO",
"Chief Growth Officer",
"VP Marketing and Communications",
"Head of Business Opportunities",
"Revenue Operations Specialist",
"Product Marketing Manager"
Revenue Ops
RevOps
Chief Revenue Officer
CRO
CMO`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}