package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+|\w+@\w+\.com)$`)
var str = `abc@gmail.com
abcgmail.com
1234567890
123456789A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}