package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[H\h]ello,? [W|w]orld!?`)
var str = `Hello, World! - Intended
hello, world! - Lower case
Hello World! - Forgot comma
Hello, World - Forgot exclamation point
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}