// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^https?:\/\/(?:[^\/]+\.)?website\.com(.*\/(?:p)+\/)").unwrap();
let string = "https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582
https://www.innovasport.com/c/p/
https://www.innovasport.com/c/prendas/
https://www.innovasport.com/p/
https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}